Installing and Updating Quantrix Modeler

When you download Quantrix from the Quantrix web site, or are sent an installer by Quantrix Sales, you will receive installation instructions. To install Quantrix, follow the written and on-screen instructions.

The 30 day trial available at https://quantrix.com/free-trial/ does not require a serial number. Serial numbers are required only for trial extensions or purchased licenses.

Installation Notes

When installing on macOS 

If you receive a security prompt (unidentified developer or Gatekeeper prompt), use System Preferences > Security & Privacy > General and choose "Open Anyway".

Note: If your Mac device has the Apple-designed M1 chip, you can use the macOS Modeler installer (the M1 installer will not run for Macs that use an Intel/AMD chip).

First-time installations only: When you finish installing Quantrix for the first time, a message displays giving you the choice to participate in Quantrix's optional anonymous usage reporting. No user or location information, or model structure or content information is reported. After you click Yes or No to the message, the message goes away and will not reappear. Should you want to change your response, you can do so at any time using Tools > Settings (accessible from either the Launch Panel or the Tools menu).

Quantrix License and Activating Quantrix

Quantrix licenses are subscription-based and require entry of a serial number provided by Quantrix.

See also About Your Quantrix Version & License

Existing licensed users can view Quantrix License information at any time by clicking Help > Quantrix License or Help > About Quantrix.  The serial number, installation ID, date activated, licensed user email and expiration date display. You can also click the Activate New Subscription button.

If you don't have a serial number or your serial number has expired, the Help menu option says  Help > Activate Quantrix, and clicking Activate Quantrix displays the License dialog where you can contact sales to purchase a license, request a trial extension, or if you already have the serial number, you can enter it (along with any proxy settings if needed) to connect to the internet to activate the serial number.

When Quantrix sales gives you the link to an installer, the initial installation of a purchased copy of Quantrix installer defaults to a trial license that you activate using the serial number Quantrix sends you in email.

On the Activate Quantrix dialog:

  • as you enter valid information in each field, a green check mark appears

  • the serial number field will not show a green check mark unless the entire serial number is entered correctly  

  • once all fields have valid values, the Next button is enabled

  • there are links to Contact Sales, and to Request Trial Extension

  • When you click the Next button, Quantrix tries to activate the serial number over the internet

When you activate successfully, Quantrix sends a confirmation email.

If activation fails, a message displays telling you how to continue.

IMPORTANT:

  • Regardless of where you invoke your Quantrix Update (from the Launch Panel, from within Modeler via the Help menu, or elsewhere), you should make sure you have saved any open models before updating (if you forget to save an open model, you will lose any unsaved changes).

  • If you have trouble Updating Quantrix, you may be able to download and use the installers from the support site.   

When you use Update Quantrix, the Updater tells you either that your version is up to date, or it reports your current version and the new version that is available.

Additionally, if there is a Show Comments link, click on it to see a brief description of what is included in the update. There may be a link to the full release notes in the Updater's comments pop-up.

The default download location is shown: use the Browse button to change to a different location.

Note that if you want to test the new version, you can install into a new folder.

Click Next and the Updater downloads the installer executable to the folder.  The next dialog box asks you whether to update now or later: notice that it prompts you to save any open models before updating. Click Open containing folder to locate to the folder to which the installer was downloaded.

Whether you install or update Modeler, as you progress through the dialogs, you see information about Qloud.

Install and Update and Qloud:

All Modeler subscriptions include access to Quantrix Qloud. To use Public Qloud, sign up for your free Qloud account to publish and use models on Qloud.
If your organization has licensed Enterprise or SaaS Qloud to share, collaborate and manage models, please paste or enter its URL. You can change it later from Tools > Settings >Qloud.

Note: When the updater runs, it automatically checks the Qloud URL to ensure the Modeler and Qloud versions are compatible: provided the versions are compatible the update continues. If the Qloud URL cannot be reached or does not support the update URL, it will attempt to use the legacy update URL to process updates.


Updating

Automatically Checking for Updates to Quantrix

You can instruct Quantrix to use your internet connection to automatically check for and install updated versions, and you can choose the frequency with which you want it to check for updates. You can always set and change your update frequency on the Options page under General Quantrix settings.

 

Updating via Launch Panel

At any time, you can Update using the Update in the lower left of the Launch Panel if an update is available.

When you click Update from the Launch Panel, one of two messages displays:

  • a message tells you that your version of Quantrix is already up to date, or,

  • a dialog displays telling you what your current version is, what the new version is, and giving you a Show Comments link so you can read about what's in the update.  If you choose to continue, the installer downloads.

Connection Problems

If you have trouble connecting to the internet during the download of the update, it may be due to a firewall setting or security software or some other problem. The image below is an example of the type of message you could see:

You may need to use a proxy setting to allow the connection, or it could be due to some other connection issue. If you are unable to resolve it, you can try downloading the installer from the support site.

Uninstalling Quantrix Modeler